quinta-feira, 29 de setembro de 2011

Mikrotik com Cache Full



Olá pessoal ! Nunca achei que o tal de cache full iria funcioar, até.... que experimentei fazer aqui e funciona mesmo. É muito louco, vc faz o download do arquivo pela primeira vez na sua banda tipo 128k e depois vc configura a banda do cache tipo 5M e quando vc faz o download novamente do arquivo ele vem pra você perto dos 5M, muito louco o negocio mesmo.
To postando as regras aqui que achei na net. Testei num MK com versão 2.6.9 Crack e funcionou. na versão 3.xx vou fazer semana que vem.O meu cache é externo ok não fica na mesma maquina do server, la tem um fedora instalado com squid rodando e o MK esta comunicando perfeitamente com o proxy-cache. Seguem as regras abaixo...

Crie estas regras no ip firewall mangle

/ ip firewall mangle
add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" action=mark-connection \
new-connection-mark=conn_squid-up passthrough=yes comment="CACHE FULL" disabled=no
add chain=output connection-mark=conn_squid-up action=mark-packet new-packet-mark=pacotes_squid-up \
passthrough=yes comment="" disabled=no
add chain=prerouting protocol=tcp dst-port=3128 action=mark-connection new-connection-mark=conn_squid-down \
passthrough=yes comment="" disabled=no
add chain=prerouting connection-mark=conn_squid-down action=mark-packet new-packet-mark=pacotes_squid-down \
passthrough=yes comment="" disabled=no

logo no queues tree coloque esta regra

/queue tree
add name="\[CACHE-FULL\] - Download" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default \
priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
add name="\[CACHE-FULL\] - Upload" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default \
priority=1 max-limit=5000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


Bem pessoal por hoje é isto aí, proxy com cache full, fica show de bola.

Nenhum comentário:

Postar um comentário